Home > Symbol Lookup > Symbol Lookup Error /usr/local/lib/libreadline.so.6

Symbol Lookup Error /usr/local/lib/libreadline.so.6

According to man page of ldconfig: ldconfig creates the necessary links and cache to the most recent shared libraries found in the directories specified on the command line, in the file Charles, MO Beans 12 DistroUbuntu Studio 9.10 Karmic Koala Re: Can't update or use package manager -- gpg error I also found a page that talked about the problem of libreadline.so.6 Whenever I try to install something with pacman, I get the error:error: GPGME error: Invalid crypto engineAnd when I run pacman-key --initI get the error gpg: symbol lookup error: /usr/lib/libreadline.so.6: undefined Browse other questions tagged octave or ask your own question. navigate here

Is there any solution for OSX? share|improve this answer edited May 12 '14 at 12:42 answered May 8 '14 at 14:18 bain 7,64722336 1 Try: find /usr/local -name '*octave*' -exec rm -rf {} \; –bain May I get the error:error: GPGME error: Invalid crypto engineIs there any other way I can install readline? tacaswell commented May 19, 2015 libCom is one of the things being built in this recipe.

Removing units ... asmeurer commented May 19, 2015 Are you using the latest version of conda-build? Thanks for your post Reply devrajpawar says: June 18, 2013 at 4:37 am Thanks, it worked for my gdl (gnudatalanguage) too.

danielballan commented May 19, 2015 @asmeurer Thanks for the suggestion, but unfortunately the readline on your channel breaks worse. Processing triggers for libc-bin ... Now type apt-get update. share|improve this answer answered Dec 29 '12 at 19:06 eppesuig 1,521169 thank you for your answer.

Feynman diagram and uncertainty Why does MIT have a /8 IPv4 block? Need to get 0 B/12.3 MB of archives. octave: symbol lookup error: /usr/local/lib/libreadline.so.6: undefined symbol: UP dpkg: error processing octave (--configure): subprocess installed post-installation script returned error exit status 127 No apport report written because MaxReports is reached already ldconfig deferred processing now taking place Processing triggers for menu ... $:/usr/local/lib$ octave /usr/bin/octave-cli: symbol lookup error: /usr/local/lib/libreadline.so.6: undefined symbol: UP $:/usr/local/lib$ ls libhistory.a libpcrecpp.a libpcreposix.so libreadline.so libSDL2main.a libhistory.old libpcrecpp.la libpcreposix.so.0

I moved libreadline.so.6, libreadline.so.6.2 to a folder, and gdl worked. Unable to understand the details of step-down voltage regulator Difficulties interpreting this complex sentence more hot questions question feed lang-sql about us tour help blog chat data legal privacy policy work Email ThisBlogThis!Share to TwitterShare to Facebook ←Newer Post Home Older Post→ 0 comments: Post a Comment Subscribe to: Post Comments (Atom) Categories . Reply Thomas says: July 18, 2012 at 9:44 am Many many thanks… :-) Reply Cesar says: August 3, 2012 at 12:34 pm Everything were said by previous bloggers.

Selenium _target = blank switch to new window how to? I am not familiar with .spkg files, so I will leave it to somebody else who is to figure out how to use it. asmeurer commented Apr 14, 2015 Try to manually install my readline (conda install -c asmeurer readline). So here is the quick fixes for this problem. 1.

It recommends running pacman -S readline to downgrade readline, but my problem is pacman won't run at all after the update to readline. http://mmonoplayer.com/symbol-lookup/symbol-lookup-error-undefined-symbol-c.html Unpacking octave-common (from .../octave-common_3.8.1-1ubuntu1~octave1~precise1_all.deb) ... Copying over the system readline shared objects to ~/miniconda3/lib seemed to have done the trick for better or worse. Setting up octave-common (3.8.1-1ubuntu1~octave1~precise1) ...

liboctave2 octave-common octave Install these packages without verification [y/N]? more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed Home About Us Expert Solutions Testing Tools Contact Us Tags Android ANT Build Tool CodeIgniter Encryption Linux MySQL PHP Python QA QC Quality Assurance Quality Control Security selenium Test Engineer Tester http://mmonoplayer.com/symbol-lookup/awk-symbol-lookup-error-awk-undefined-symbol-mpfr-z-sub.html They have been ignored, or old ones used instead.

askubuntu.com/questions/110215/… –fossfreedom♦ Mar 5 '12 at 15:00 @guntbert: What should i have to do if i have an lucid lts Version ? Last edited by whitebrice (2014-04-03 23:06:34) dotfiles Offline #7 2014-04-03 23:05:44 fukawi2 Forum Moderator From: .vic.au Registered: 2007-09-28 Posts: 5,326 Website Re: [Solved] Undefined symbols in libreadline.so.6 whitebrice wrote:Aside: I recently Errors were encountered while processing: octave Warning: Something went wrong, packages may not have been reverted octave share|improve this question edited May 10 '14 at 18:00 bain 7,64722336 asked May 3

Any ideas?

I've seen this error a lot and that's usually the culprit. –Mike Miller May 5 '14 at 23:29 1 try this: $sudo rm -rf /usr/local/bin/octave –j0h May 6 '14 at Both of them are important for my project. Adv Reply August 31st, 2010 #5 samicom View Profile View Forum Posts Private Message First Cup of Ubuntu Join Date Mar 2008 Beans 7 Re: Can't update or use package Setting up liboctave2 (3.8.1-1ubuntu1~octave1~precise1) ...

rpy2 was installed using pip. Octave 3.8.1 will definitely work with the readline and ncurses provided in the repos. Any help would be greatly appreciated.Aside: I recently enabled gnome-unstable, testing, and community-testing repos so that I could run Gnome 3.12, but it appears I have done so before I had weblink Processing triggers for menu ...

tacaswell commented May 20, 2015 Either recipe in this folder: https://github.com/tacaswell/conda-prescriptions/tree/working/releases/epics-base And I believe latest version of conda-build everywhere we have tried this. Actually we are going to remove these libraries, and in case of emergency you know what to do. Like Us Home Home Labels Android ANT Build Tool CodeIgniter Encryption Linux MySQL PHP Python QA QC Quality Assurance Quality Control Security selenium Test Engineer Tester Testing tools VirtualBox Weblogic Windows Do you want to continue [Y/n]?

dotfiles Offline Pages: 1 Index »[testing] Repo Forum »[Solved] Undefined symbols in libreadline.so.6 Board footer Jump to Newbie Corner Installation Kernel & Hardware Applications & Desktop Environments Laptop Issues Networking, Server, Thank you very much!!! gpggpg: symbol lookup error: /usr/local/lib/libreadline.so.6: undefined symbol: UP : symbol lookup error: /usr/local/lib/libreadline.so.6: undefined symbol: UP dpkg: error processing ubuntu-keyring (--configure): subprocess installed post-installation script returned error exit status 127 Errors How should I tell my employer?

craffel referenced this issue in craffel/pretty-midi Jul 6, 2016 Closed Had trouble importing pretty_midi on Ubuntu #69 xiaoqiangwang pushed a commit to paulscherrerinstitute/pcaspy that referenced this issue Jul 12, 2016 wang_x1 Processing triggers for desktop-file-utils ... any other solutions? It seems to work in an ubuntu box, but am having issues finding libtinfo during the link step on an arch linux box.

If you have not installed any other packages to /usr/local, then do: find /usr/local -type f -exec rm -f {} \; Do not do that if you have installed other packages